Installing TSM Tivoli Client 6.4 or 7.1 on RHEL7 / CentOS 7 with Failed dependencies: libc.so.6 is needed

Today I got a problems installing TSM Tivoli Client 6.4 and also 7.1 on CentOS 7.
Commands I run

rpm -Uhv gskcrypt64-8.0.14.14.linux.x86_64.rpm
rpm -Uhv gskssl64-8.0.14.14.linux.x86_64.rpm
rpm -Uhv TIVsm-API64.x86_64.rpm

doing than

rpm -Uhv TIVsm-APIcit.x86_64.rpm

gives error message

error: Failed dependencies:
libc.so.6 is needed by TIVsm-APIcit-6.4.0-0.x86_64
libc.so.6(GLIBC_2.0) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libc.so.6(GLIBC_2.1) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libc.so.6(GLIBC_2.1.3) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libc.so.6(GLIBC_2.2) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libc.so.6(GLIBC_2.3) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libc.so.6(GLIBC_2.3.2) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libdl.so.2 is needed by TIVsm-APIcit-6.4.0-0.x86_64
libdl.so.2(GLIBC_2.0) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libdl.so.2(GLIBC_2.1) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libgcc_s.so.1 is needed by TIVsm-APIcit-6.4.0-0.x86_64
libgcc_s.so.1(GCC_3.0) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libgcc_s.so.1(GLIBC_2.0) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libm.so.6 is needed by TIVsm-APIcit-6.4.0-0.x86_64
libnsl.so.1 is needed by TIVsm-APIcit-6.4.0-0.x86_64
libpthread.so.0 is needed by TIVsm-APIcit-6.4.0-0.x86_64
libpthread.so.0(GLIBC_2.0) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libpthread.so.0(GLIBC_2.1) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libpthread.so.0(GLIBC_2.2) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libpthread.so.0(GLIBC_2.3.2) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libstdc++.so.5 is needed by TIVsm-APIcit-6.4.0-0.x86_64
libstdc++.so.5(CXXABI_1.2) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libstdc++.so.5(GLIBCPP_3.2) is needed by TIVsm-APIcit-6.4.0-0.x86_64
libstdc++.so.5(GLIBCPP_3.2.2) is needed by TIVsm-APIcit-6.4.0-0.x86_64

and after resolving first error I got

libgcc_s.so.1 is needed

and than I got

libstdc++.so.5 is needed

this also is true for trying tsm tivoli 7.1 client version
Solution was to install missing Linux 32-bit libraries [1] as tsm relies on them

yum install libgcc.i686
yum install libstdc++.i686
yum install compat-libstdc++-33-3.2.3-72.el7.i686

sources
[1] http://www-01.ibm.com/support/docview.wss?uid=swg21608859